/ Разработка

Ubuntu 16.10: Чего ожидать от Unity 7

На прошлой неделе вы могли наблюдать за циклом разработки Ubuntu 16.10 во время Ubuntu Online Summit.

Трехдневное мероприятие дает нам грубое представление о направлении развития ‘Yakkety Yak’ и его значении для нас.

Возможно, в одной из следующих статей я расскажу об этом подробнее для тех, кто не следил за ходом мероприятия.

Unity 7 еще с нами

Самой громкой новостью оказалась информация, что Unity 8 и Mir не будут стандартными оболочками в следующем релизе.

Вас не печалит тот факт, что многообещающим технологиям не дают шанса?

Но с другой стороны, это правильное решение. Ведь мы не хотим раздолбать наши компы в порыве ярости, если что-то пойдет не так.

Будем откровенны: Над Unity 8 нужно еще поработать

Нельзя недооценивать объем работ, необходимый для корректного функционирования сервера Mir и оболочки Unity 8.

Те, кто частенько выпивают/живут в своем собственном мире могут утверждать, что оболочка уже вполне хорошо работает. Я не отрицаю, что ей можно пользоваться, но она еще даже не ровня Unity 7.

Если уж и питать надежды о том, что Unity 8 когда-либо станет стандартной оболочкой и заменит Unity 7 на миллионах компьютерах по всему миру - то восьмерке нужно, определенно, становиться лучше.

Но что же данная задержа может означать для релиза Yakkety?

Ubuntu 16.10: Чего ожидать

Unity 7

Unity 7 не сильно изменится во время данного цикла разработки. Будут задеты только существенные баги, проблемы безопасности и OEM.

То есть мы не увидим новых функций? Не совсем. Вполне возможно, что парочка новых возможностей просочится.

Но любые существенные изменения должны быть смотивированы комьюнити!

ISO образ станет больше

Разработчики тактично согласились увеличить размер образа для Ubuntu 16.10.

Поскольку DVD - это пережиток прошлого. Дешевизна и доступность USB носителей объемом выше 1GB позволяет принимать подобные решения.

Это не означает, что Ubuntu 16.10 будет полон новых фишек и приложений, но можно ожидать поддержку большего количества языков.

Библиотеки и пакеты

Ubuntu 16.10 вероятнее всего будет использовать GNOME 3.20, который вышел еще в марте. Для этого нужно пропатчить некоторые GNOME приложения, включая Totem, Eye of GNOME и Evince, чтобы они продолжили корректно работать с менюшками от Unity 7.